Test reconnaissance vocale

Dans la série des expérimentations, un test sur la reco vocale.

Problématique

Qui dit reconnaissance vocale, dit micro, capture de son.
Voici les quelques essais que j'ai fait. Dans cette page : Installation d'un micro

TEST Kalliope

Prérequis

Il faut quelques dépendances python :

sudo apt install build-essential libssl-dev libffi-dev python-dev

Ensuite on suit le Tuto.

git clone https://github.com/kalliope-project/kalliope.git
cd kalliope
sudo python setup.py install

Un petit test :

rec test.wav -> rec n'est pas installé, utiliser arecord
mplayer test.wav

Ensuite on configure Kalioppe pour le Français :

git clone https://github.com/kalliope-project/kalliope_starter_fr.git
cd kalliope_starter_fr
kalliope start

Et là, ça bloque :


Traceback (most recent call last):
File "/usr/local/bin/kalliope", line 5, in <module>
  from pkg_resources import load_entry_point
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2876, in <module>
  working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 451, in _build_master
  return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 464, in _build_from_requirements
  dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 639, in resolve
  raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pyalsaaudio>=0.8.4

—– Du coup je télécharge pyalsaudio et je compile :

git clone https://github.com/larsimmisch/pyalsaaudio.git
cd pyalsaaudio
python setup.py build
sudo python setup.py install

Reessai mais encore un bug


Traceback (most recent call last):
File "/usr/local/bin/kalliope", line 5, in <module>
  from pkg_resources import load_entry_point
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2876, in <module>
  working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 449, in _build_master
  ws.require(__requires__)
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 745, in require
  needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 639, in resolve
  raise DistributionNotFound(req)

pkg_resources.DistributionNotFound: apscheduler>=3.3.1


banana/reco.txt · Dernière modification: 2019/08/13 12:16 (modification externe)
CC Attribution-Share Alike 4.0 International
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0